The Great Migration #2 - (Partially Completed)

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

The Great Migration #2 - (Partially Completed)

Post by Spec8472 » Thu Jan 22, 2009 2:23 pm

If you're seeing this message - then you're on the new forums.

See below for details on what's been migrated/etc.

---

The entire Sennadar forums, website, wiki, and a LOT more is being migrated this weekend from about Friday 30th of January, 2009 to Sunday 1st February, 2009.

Obviously during the migration the forums will be placed in a Locked / Administration mode.

You do not need to do anything to see the new forums, your computer and/or ISP will automatically update to see the new address details - typically within a few hours. In rare occasions, this can take up to a week to update.

For the terminally forum addicted, I'd recommend you take a moment to bookmark or follow @sennadar on Twitter. This account will have updates on the migration progress and any delays in the process.

-----
Original Message follows.

There's been some issues with the hosting over the last few months - mainly due to the load.

I requested it be upgraded to have more resources, and just recieved the email that it's been cut over. It's currently operating with a very high allocation of resources on a trial basis until we can figure out the baseline for the demand.

For the technically inclined, it's currently on a virtual private server, configured with 2.3GB RAM. Yes, I'm looking at dedicated hosting, again.

Please reply here if you get any "Server Error" error messages.

gnume
Sui'Kun
Posts: 315
Joined: Tue Apr 22, 2008 6:25 pm

Re: Sennadar.com Upgrades (2008)

Post by gnume » Thu Jan 22, 2009 2:46 pm

ouch

Dreamer
Initiate
Posts: 43
Joined: Mon Aug 20, 2007 10:53 pm

Re: Sennadar.com Upgrades (2008)

Post by Dreamer » Fri Jan 23, 2009 6:46 am

Everytime I try to access the http://www.sennadar.com main page, I get the following errors:

Warning: require_once(/home/sennadar_domain/sennadar.com/wp/wp-config.php) [function.require-once]: failed to open stream: Permission denied in /home/sennadar_domain/sennadar.com/wp/wp-load.php on line 27

Fatal error: require_once() [function.require]: Failed opening required '/home/sennadar_domain/sennadar.com/wp/wp-config.php' (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php') in /home/sennadar_domain/sennadar.com/wp/wp-load.php on line 27

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: Sennadar.com Upgrades (2008)

Post by Spec8472 » Sat Jan 24, 2009 9:57 am

Okay, so that last 36hrs of outage was because of the migration... for some reason the host decided to update certain bits before other bits were ready, and ended up causing the entire thing to come crashing down.

Things are still a bit iffy.

Edit: And we're now at ~1.5GB of actual memory used out of the 2.3GB allocated.

Gauthier
Novice
Posts: 13
Joined: Wed Dec 05, 2007 11:33 pm

Re: Sennadar.com Upgrades (2008)

Post by Gauthier » Sat Jan 24, 2009 6:43 pm

The wiki is still down
http://wiki.sennadar.plebian.net/

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: Sennadar.com Upgrades (2008)

Post by Spec8472 » Sun Jan 25, 2009 1:55 am

PHP is a memory hog - 2.3GB allocated, 100% used about 3hrs ago. Rebooting the virtual server to get things working again.
index.cgi.png
index.cgi.png (2.97 KiB) Viewed 6534 times

User avatar
Shadowhawk
Child of Niami
Posts: 776
Joined: Thu Jan 22, 2004 12:17 am
Location: Poland
Contact:

Re: Sennadar Wiki is still down

Post by Shadowhawk » Sun Jan 25, 2009 1:40 pm

Gauthier wrote:The wiki is still down
http://wiki.sennadar.plebian.net/
Sennadar Wiki (BTW. shouldn't Sennadar Forum include link to wiki, and to the books?) now generates the following error:
http://wiki.sennadar.plebian.net/ wrote: Warning: dir(/home/.ramal/sennadar_domain/wiki.sennadar.plebian.net/skins) [function.dir]: failed to open dir: No such file or directory in /home/sennadar_domain/wiki.sennadar.plebian.net/includes/Skin.php on line 23

Fatal error: Call to a member function on a non-object in /home/sennadar_domain/wiki.sennadar.plebian.net/includes/Skin.php on line 26
BTW. wouldn't mod_php be a better solution than mod_fastcgi / mod_fcgi in this case?
I AM DEATH, NOT TAXES. *I* TURN UP ONLY ONCE.
(Terry Pratchet, "Feet of Clay")

gnume
Sui'Kun
Posts: 315
Joined: Tue Apr 22, 2008 6:25 pm

Re: Sennadar.com Upgrades (2008)

Post by gnume » Sun Jan 25, 2009 1:52 pm

this is mod_php

Gauthier
Novice
Posts: 13
Joined: Wed Dec 05, 2007 11:33 pm

Re: Sennadar.com Upgrades (2008)

Post by Gauthier » Sun Jan 25, 2009 8:30 pm

this is mod_php
Since the problem is a memory leak switching to fastcgi will solve the memory problem and improve server responsiveness.
in effect memory is 100% released at the killinterval (300 sec I think)

The culprit could be K2 for wordpress or the phpBB search.

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: Sennadar.com Upgrades (2008)

Post by Spec8472 » Sun Jan 25, 2009 11:55 pm

The cause could be any number of things on any of the sites running on here - diagnosing and fixing the issue isn't going to be easy when I can't see what's using what.

The easiest fix for the moment is to just reboot the server once a day, before it reaches the memory limit (temporarily at 4GB).

When I get the dedicated server, I'll be able to fix the memory leaks - at the very least by forcing the FastCGI pool to cycle the worker processes after a certain amount of time.

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: Sennadar.com The Great Migration #2 (2009)

Post by Spec8472 » Wed Jan 28, 2009 9:07 pm

I've ordered the new server, I'll be doing the migration this weekend assuming it's all available.

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: The Forums are moving THIS WEEKEND

Post by Spec8472 » Fri Jan 30, 2009 4:36 pm

I've managed to migrate the forums over in a test mode, and from what I can see it all works.

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: The Forums are moving THIS WEEKEND

Post by Spec8472 » Sat Jan 31, 2009 3:42 am

Welcome. If you can see this post, you're on the new server. Yay.

Things should be much more stable now, it's on it's own dedicated server.

User avatar
Lochar
Leaders of the Off-Topic
Posts: 1462
Joined: Thu Oct 09, 2003 4:18 pm
Location: The center of American corruption.
Contact:

Re: The Great Migration #2 - (Partially Completed)

Post by Lochar » Sat Jan 31, 2009 3:11 pm

RSS Feed seems to be funky.
Ignorance is bliss, knowledge is power. Are the powerful very unhappy?

Support my brother.
http://www.justiceformichael.com

Spec8472
Weavespinner
Posts: 1534
Joined: Sun Apr 06, 2003 12:00 am

Re: The Great Migration #2 - (Partially Completed)

Post by Spec8472 » Sat Jan 31, 2009 3:24 pm

Lochar wrote:RSS Feed seems to be funky.
Fixed.

Locked